Alpine Linux promtail-linux-amd64 file not found

Если не запускается promtail-linux-amd64 На Alpine Linux, нужно выполнить команду:

apk add libc6-compat

Проблема возникает из-за того что в Alpine Linux используется библиотека musl. Поэтому нужно установить дополнительный пакет, который установит нужные библиотеки

Подробнее:

  1. https://github.com/grafana/loki/issues/838
  2. https://stackoverflow.com/questions/66963068/docker-alpine-executable-binary-not-found-even-if-in-path

Остались вопросы?

Если вы хотите получить консультацию или оставить комментарий, заполните форму ниже:
Укажите ваше имя:
Укажите вашу почту, чтобы я смог вам ответить:
Напишите ваш вопрос или комментарий: